Page MenuHomeAleph Objects Inc

Communication speed reset
Closed, ResolvedPublic

Description

When you select your communication speed then change your port, the communication gets set back to auto

Event Timeline

west created this task.Mar 27 2018, 9:29 AM
karrad changed the edit policy from "Custom Policy" to "Restricted Project (Project)".Mar 28 2018, 7:40 AM
karrad reassigned this task from karrad to TKostennov.Mar 28 2018, 7:47 AM
karrad triaged this task as Normal priority.
karrad added subscribers: TKostennov, karrad.

@TKostennov It looks like every time we restart cura, it will default back to: Port "auto" and Communication Speed "Auto"

When first adding a machine, we would like the default Port to be "Auto" and the speed to be 250000 when first adding a machine.

If a customer changes these settings for a specific machine, we would like to keep those settings upon restarting Cura.

Steps to duplicate:
1.) Launch Cura and open machine settings
2.) Change port and speed for that specific machine
3.) Restart cura and check that machine

Expected Results: The changes to port and speed are remembered
Actual Results: Port and speed change back to "auto"

karrad moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Mar 28 2018, 7:47 AM
west added a comment.Mar 28 2018, 10:31 AM

When you select a port in machine settings, the port is different on the control screen. ( see top right corner for the control screen port)

@karrad Now settings remembered after restart.
@west When you connected to a printer and change connection port in settings you need to reconnect to a printer to apply changes.

karrad closed this task as Resolved.Apr 3 2018, 10:15 AM

@TKostennov Thanks looks great!