Page MenuHomeAleph Objects Inc

BUG: Resume button not working after print pause
Closed, DuplicatePublic

Description

While testing 3.2.19 on Mac OS X, I mistakenly clicked the pause button while printing. Attempted using the resume button to continue the print and it does not do anything. We have been able to replicate this on both of our Mac systems (High Sierra and El Capitan), however I tried to replicate in Ubuntu and resume button worked. I will update this ticket if I find this issue in Windows or Debian.

Event Timeline

Yahuba created this task.May 1 2018, 2:36 PM
karrad assigned this task to TKostennov.May 2 2018, 12:22 PM
karrad triaged this task as Normal priority.
karrad moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.
karrad changed the edit policy from "Custom Policy" to "Restricted Project (Project)".
karrad renamed this task from Resume button not working after print pause to BUG: Resume button not working after print pause.
Yahuba added a comment.May 2 2018, 2:47 PM

reproduced in Debian as well using 3.2.19

@Yahuba can you please write a steps to reproduce? I can't reproduce this on debian by click pause button and resume button after that while printing.(3.2.19 and devel)

@TKostennov I think I figured this out. I believe this is only happening if you pause print soon after you start print while extruder is still pre-heating but before it actually starts the print. Seems to be the only way I have been able to reproduce it today.

karrad added a subscriber: karrad.May 4 2018, 10:11 AM

@Yahuba Ahh this looks to be a duplicate of T2175. I think the issue is the start up gcode gets mostly buffered, and will wait to allow a resume