Page MenuHomeAleph Objects Inc

[Ubuntu] Missing dependency
Closed, ResolvedPublic

Description

As reported by a user here: https://forum.lulzbot.com/viewtopic.php?f=8&t=2959&start=10#p19519
python-wxgtk3.0 is not provided by Ubuntu 14.04 LTS (but 14.10 does)

One workaround is to use this PPA: https://launchpad.net/~adamwolf/+archive/ubuntu/kicad-trusty-backports

Event Timeline

nickthetait updated the task description. (Show Details)
nickthetait raised the priority of this task from to Normal.
nickthetait added a project: Cura.
nickthetait moved this task to Backlog on the Cura board.
nickthetait added a subscriber: nickthetait.

I also encountered this issue on Ubuntu 14.04 LTS (Trusty Tahr).

This thread https://forum.lulzbot.com/viewtopic.php?f=8&t=2959&p=19519&hilit=ubuntu#p19519 pointed me here. The solution outlined worked. I just wanted to be more explicit with the steps I took. I had previously installed Cura Lulzbut edition using these instrxns for Ubuntu: https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-debian

From the PPA page ( https://launchpad.net/~adamwolf/+archive/ubuntu/kicad-trusty-backports ), I needed to add this source to my APT sources.list:

deb http://ppa.launchpad.net/adamwolf/kicad-trusty-backports/ubuntu trusty main

sudo vi /etc/apt/sources.list
## add the PPA 'deb' line to bottom of the file
sudo add-apt-repository ppa:adamwolf/kicad-trusty-backports
sudo apt-get update
sudo apt-get install cura

cura should now report being the newly installed 18.03 version when launched.

Cheers!

nickthetait closed this task as Resolved.May 12 2016, 2:34 PM

Fixed by increasing the system requirements for Ubuntu