Debian dependency issue
Closed, ResolvedPublic

Description

Cura LE Version: 3.2.32

Operating System: Ubuntu 18.04

Printer: ?

Tool Head: ?

Description of issue: Package libssl1.0.2 is not installed.

Steps to reproduce: Much like the issue in T4341

Upload cura-lulzbot.log (attachment)

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl1.0.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl1.0.2' has no installation candidate

Ubuntu 18.04 already has libssl 1.0.2n installed as shown here:

kevink@Lulzbot:~$ apt-cache policy libssl1.0.0
libssl1.0.0:

Installed: 1.0.2n-1ubuntu5.1
Candidate: 1.0.2n-1ubuntu5.1
Version table:

Related Objects

nathan created this task.Wed, Nov 21, 11:22 AM
karrad changed the edit policy from "Custom Policy" to "Cura LulzBot Edition (Project)".Wed, Nov 21, 11:40 AM
karrad assigned this task to alexei.
karrad moved this task from Backlog to Next Release (3.2) on the Cura LulzBot Edition board.
karrad triaged this task as Normal priority.
karrad added subscribers: alexei, karrad.

@alexei I am not sure if we need a similar update as T4341 for the ubuntu packages

@karrad ,
Not sure why Ubuntu renamed the base name for libssl. I guess this is one good example why releases based on non-frozen Debian should not be done.
For buster build this package should be installed:
https://packages.debian.org/buster/libssl1.0.2

alexei added a comment.Tue, Dec 4, 8:22 AM

As a temporary solution I have this package http://download.alephobjects.com/ao/aodeb/dists/buster/main/binary-amd64/libssl1.0.2_1.0.2q-2_amd64.deb
placed in our repo. It was taken from here: https://packages.debian.org/buster/libssl1.0.2
This should at least solve the problem with manual installation on Ubuntu.

alexei closed this task as Resolved.Wed, Dec 5, 1:11 PM