Page MenuHomeAleph Objects Inc

Nozzle 2 does not purge
Closed, ResolvedPublic

Description

At the start of every print, the printer will purge some filament from nozzle 1, then switch and do the same for nozzle 2. However, nozzle 2 is never purged for long enough for filament to come out. I used a stopwatch and watched: nozzle 1 spent about 16 second purging about 195mm of filament, then nozzle 2 spent about 8 seconds purging 0mm of filament. (This was after priming both nozzles before starting a print.)

It doesn't make sense to me as the gcode for both nozzles is the same.

M117 Purging...                           ; LCD status message
T0                                        ; select this extruder first
G1  E0 F100                               ; undo retraction
G92 E-15                                  ; set extruder negative amount to purge
G1  E0 F100                               ; purge XXmm of filament
T1                                        ; switch to second extruder
G1  E0 F100                               ; undo retraction
G92 E-15                                  ; set extruder negative amount to purge
G1  E0 F100                               ; purge XXmm of filament
G1 Z0.5                                   ; clear bed (barely)
G1 X100 Y0 F5000                          ; move above bed to shear off filament

This doesn't affect the print since by the time it does the skirt for nozzle 2 it's extruding.

Event Timeline

matth created this task.Jan 4 2019, 4:00 PM
matth triaged this task as Normal priority.

@matth We made some changes just about an hour ago to the start and end gcode that @anolen had been working on: https://code.alephobjects.com/rCTc795dc29b29693dba6de16daf0049493cc3a3a80

Can you try this one and see if the issues persists?

matth added a comment.Jan 7 2019, 11:54 AM

I added the start and end gcode and still have the same issue. I timed the nozzle 1 purge to be about 12 seconds and the nozzle 2 purge to be about 6 seconds. While both nozzles did purge some filament, I'm still not sure why nozzle 2 always seems to purge for half the time/amount that nozzle 1 does.

In the new start code I upped the 2nd nozzles extrusion by 5mm, nozzle 1 should be purging 15mm and nozzle 2 should be purging 20mm. However, I also still see the 2nd nozzle purge less and if it goes directly from ending one print to starting the next, the amount the 2nd nozzle purges is even less! You only get about 7 mm coming out of the hot end, not even enough for the bed movement to sheer off. @matth, I am with you on this, not sure what is going on there.

matth added a comment.Jan 9 2019, 11:11 AM

This seems to have been resolved with the current firmware update 2.0.0.67. I'll measure it more, but in my last print both extruders purged about 170mm.

kent closed this task as Resolved.Jan 9 2019, 11:49 AM
kent claimed this task.
kent added a subscriber: kent.

Cool thanks for testing @matth.