Page MenuHomeAleph Objects Inc

y bed plate ground/tvs attachment
Closed, ResolvedPublic

Description

@mjpelletier raised some concerns about the reliability of the ground connection on the y bed plate. Currently the ring terminals are being held in place by a printed part. Due to variance in printed parts, there may be issues with getting good electrical contact.

The proposed fix:
fasten lugs to plate with stainless screw/lock washer then attach bracket over the lugs.
This will require a change to the printed part as well as some additional hardware to make work
This change should make installing the ground lugs to the plate easier as it will be easier to line them up

FWIW all 20 machines built with the current set up do not have grounding issues.

Event Timeline

tutley created this task.Jan 8 2019, 8:48 AM
DaniAO added a subscriber: DaniAO.Jan 14 2019, 12:54 PM

@tutley we were able to pass testing with the way that it currently designed correct?

per @west this change would require adding hardware to the bed as well as a change in 2x printed parts. Being that we are so close to Betas, is the change needed?

@Steven @mjpelletier what are your thoughts?

logan added a comment.Jan 14 2019, 1:16 PM

@DaniAO @west this was changed a bit by the additional ring terminal for the TVS diode on the bed extension harness right? With the 3rd ring terminal it should be a tighter fit

so then we don't need this change any more? @west if this is true, please close the ticket.

Thanks!

tutley closed this task as Resolved.Jan 16 2019, 1:20 PM
tutley claimed this task.

We are passing EMI/ESD and all alphas had a solid ground connection to the bed plate. I think this is a non issue