Page MenuHomeAleph Objects Inc

Cura 3.2.32 for Windows having difficulty with 100MB+ files
Open, NormalPublic

Description

Cura LE Version: 3.2.32

Operating System: Windows both 7 and 10

Printer: Taz 6

Tool Head: Stock Extruder

Description of issue: Customer is unable to load large files into Cura LE, receives an Invalid File error. Is able to load same files in Ultimaker Cura and S3D without issue. Has tried files on 3 different computers at their work and all produce the same issue. This seems to be Windows specific because when they sent files over to us we were able to open them just fine on our computers.
The specs for the 3 computers tried are listed below:
Dell, precision 7920 Rack workstation Windows 10 Pro, 48 GB ram, Intel Xeon Gold 6130 2.1GHz, 3.7GHz Turbo, Nvidia 7920 rack
Dell XPS 15 9560, Intel i7-770HQ @ 2.80 GHz, 16 GB ram, Windows 10 Pro
Custom tower workstation, Gigabyte board Intel I5-8500T, 256 GB ram, Windows 7 professional

Steps to reproduce: Based on customer experience you should just need to load a very large file (100MB+) into Cura 3.2.32 using Windows computer. We were unable to reproduce using Linux computer in office.

Customer sent in several log files, I have included the most recent one but can also include older ones if that would help just let me know.

Event Timeline

Galadriel created this task.Jan 9 2019, 7:39 AM
karrad added a subscriber: karrad.Jan 9 2019, 9:07 AM

@Galadriel Can you get us an example file to test with?

We have also seen compatibility issues with multiple versions of Cura installed on a single computer, would they be able to uninstall other versions and clear cache?

alexei triaged this task as Normal priority.Jan 9 2019, 1:42 PM
alexei changed the edit policy from "All Users" to "Cura LulzBot Edition (Project)".
alexei added a subscriber: alexei.Jan 9 2019, 1:50 PM

@karrad ,
This is most probably numpy-stl or numpy problem.

2019-01-07 19:29:57,972 - ERROR - [(5884)-Thread-7] UM.Logger.logException [82]: Exception: Exception occurred while loading file C:/Users/Kelly/Documents/3D Printing/Wind Turbine/AS_3000_01_Rotor_Assembly/AS_3000_01 Rotor Assembly/Nose Cone.STL
2019-01-07 19:29:57,975 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]: Traceback (most recent call last):
2019-01-07 19:29:57,977 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\UM\FileHandler\ReadFileJob.py", line 66, in run
2019-01-07 19:29:57,979 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\UM\Mesh\MeshFileHandler.py", line 39, in readerRead
2019-01-07 19:29:57,981 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\UM\Scene\SceneNode.py", line 117, in setCenterPosition
2019-01-07 19:29:57,984 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\UM\Mesh\MeshData.py", line 159, in getTransformed
2019-01-07 19:29:57,986 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\UM\Mesh\MeshData.py", line 290, in transformVertices
2019-01-07 19:29:58,003 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\numpy\lib\arraypad.py", line 1394, in pad
2019-01-07 19:29:58,007 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]:   File "C:\buildbot\win-slave1\CuraLEDevel-windows\build\build\inst\lib\python3.5\site-packages\numpy\lib\arraypad.py", line 139, in _append_const
2019-01-07 19:29:58,010 - ERROR - [(5884)-Thread-7] UM.Logger.logException [86]: MemoryError

Most probably connected to this: T2559

jebba added a subscriber: jebba.Mar 22 2019, 1:18 PM

It is probably due to 32 bit build, instead of 64 bit build (?).