Page MenuHomeAleph Objects Inc

backlash values from auto calibration not retained during power cycle
Closed, ResolvedPublic

Description

Steps to reproduce:
Run auto nozzle calibration
See backlash values in menu
Power cycle the printer
See no backlash values in menu

Event Timeline

logan created this task.Thu, Jan 10, 9:29 AM
logan triaged this task as Normal priority.
logan created this object with edit policy "LulzBot Hardware Products (Project)".
logan added a project: Marlin.

AFAIK, this was fixed in the later versions of FW.

DaniAO added a subscriber: DaniAO.Fri, Jan 11, 8:21 AM

@logan which firmware are you on?

You should be using .67

@marcio do you know what version this was fixed in?

It looks like .49.

Logan, look at your console and see what errors are getting printed. It must be failing to save to EEPROM, and the console will tell you why.

I was on .67 yes
I confirmed the same thing on @EricNugent's machine but @matth's machine retained the data. We should all be on .67.

Once my machine is back together next week I can try again

@logan:

Three things to try:

1 - Check the serial console for errors when running M500
2 - Restore Factory Settings.
3 - Erase the SPI Flash Chip:
     - Go to "About Printer"
     - Touch the "(C) 2018 Aleph Objects, Inc" string
     - From the Developer menu, click "Erase SPI flash"
matth added a comment.Fri, Jan 11, 9:49 AM

Tried the steps to reproduce and my machine, Quiver 1, retained the backlash values after power cycling. I'm running .67

karrad closed this task as Resolved.Wed, Jan 16, 4:21 PM
karrad added a subscriber: karrad.

Testing on Marlin 2.0.0.72 my backlash values are saved automatically after running calibration, and they retained the values after a power cycle. Going to close this one out.