Page MenuHomeAleph Objects Inc

Calibration screen quickly exits to main menu
Closed, ResolvedPublic

Description

Marlin 2.0.0.77 HS+

As discovered in T5457, the calibration screen displays for a split second, then exits to the main menu without giving the user a chance to tap the calibration dots.

Event Timeline

youngmrcarlson created this object with edit policy "AO (Project)".
youngmrcarlson renamed this task from Calibration screen doesn't all to Calibration screen quickly exits to main menu.
marcio added a subscriber: marcio.Jan 24 2019, 1:08 PM

@youngmrcarlson: I am unable to reproduce this. The calibration screen will only show up if the touch screen is detecting a touch at startup. It looks like your touch screen may be registering invalid touches -- possibly something is causing those false touches?

oliver added a subscriber: oliver.EditedJan 24 2019, 1:22 PM

@marcio After creating the fixture to test the touch screens I did notice that without the usb plugged in, when trying to calibrate the screen it will go grey for a second and quickly snap right to the main screen. My guess is it could be the marlin interrupting the screen calibration to display some error message.

This was caused when the usb board was not plugged in.

@oliver: You mean with the USB board not plugged in, correct? Or with a USB flash drive not plugged in?

@oliver: That makes sense. If the board is not present, it will try to show an error message and this would cause it to jump to the status screen, even if the calibration screen was up.

@oliver Thanks for mentioning that! I discovered that the issue exists when the USB flash drive is plugged in. If I unplug it, I'm able to calibrate.

@youngmrcarlson Cool.
@marcio It sounds like the usb board is general is overriding all other commands on start up.

I can also confirm that this is the case with mine as well. Currently running FW 2.0.0.77.

tutley added a subscriber: tutley.Jan 25 2019, 9:24 AM

i am not having any issues with calibration on .78

oliver added a comment.EditedJan 25 2019, 9:41 AM

I can confirm that I am still seeing this issue on my printer running FW .78 when the usb is plugged into the printer

Quick edit: I can confirm that this is an issue with the usb take precedent over the functions of the lcd. If you begin the calibration with any usb, it will hang until you complete it. How ever you can force the calibration to end by inserting the usb.

@oliver i also have the USB plugged in and i am not seeing this. however my unit has all the upgrades for EMI/ESD. Maybe this is why i am not seeing this

@tutley Could be, this is something we can do a final confirmation on beta units than.

@oliver: I see. What happens is that if the USB thumb-drive is plugged in, it jumps to the main screen to show that the drive was inserted, this will typically happen before the calibration screen has completed.

I don't see this as a huge problem, as users will not often have to run a calibration, but I could add an extra check to prevent this from happening.

This will be addressed in .79

karrad assigned this task to adam.Jan 29 2019, 10:01 AM
karrad added subscribers: adam, karrad.

Testing on SL 2.0.0.79 with USB plugged in I am able to calibrate.

@adam can you test with the dual tool head firmware? If it checks out, go ahead and close this down.

Plugging in USB drive while in calibration screen also did not kick back to main menu. I was able to complete calibration as expected

adam closed this task as Resolved.Jan 29 2019, 10:55 AM

LCD calibration is working fine with USB flash drive plugged in from the start and halfway through calibration.