Page MenuHomeAleph Objects Inc

Redgum initial Marlin Feedback
Closed, ResolvedPublic

Description

Log initial Marlin feedback for redgum here.

  • When updating Z offset via GLCD, it does not save once clicking in the button as before. Please update to automatically save settings onces this is updated.
  • Front right probe point does not hit flat of washer, but on the "conical" shape of the nozzle making contact with the edge of the washer. a 2mm adjustment should give plenty of room for variance.
    • Redgum FW .96
  • We need to home the Z axis when first powering on
  • GLCD Knob Sensitivity when setting temperature needs adjusted
    • We go from 0-100 slow, 100-200 medium, and 200-300 goes very fast. Can we reverse this order?

Event Timeline

karrad created this task.Mar 15 2019, 8:19 AM
karrad triaged this task as Normal priority.
karrad created this object with edit policy "Redgum (Project)".
karrad updated the task description. (Show Details)Mar 15 2019, 8:23 AM
karrad updated the task description. (Show Details)Mar 15 2019, 11:02 AM
karrad updated the task description. (Show Details)Mar 26 2019, 11:16 AM
karrad updated the task description. (Show Details)
karrad updated the task description. (Show Details)Mar 26 2019, 11:43 AM
west added a subscriber: west.Mar 27 2019, 9:07 AM

The x min position is -32, for dual compatibility we need to change it to -51

karrad reassigned this task from karrad to marcio.Mar 29 2019, 10:45 AM
karrad added a project: Marlin.
marcio added a comment.EditedMar 29 2019, 2:01 PM

We go from 0-100 slow, 100-200 medium, and 200-300 goes very fast. Can we reverse this order?

Marlin only has two behaviors for the encoder. One keeps the rate of change consistent, the other causes an acceleration the longer you are turning the encoder, so you will reach your destination sooner. This is not based on the value itself, but on the amount of time you have been turning. We could turn down this acceleration effect, but it would affect all of Marlin, not just the temperature. I don't think this is a new feature, BTW.

Front right probe point does not hit flat of washer, but on the "conical" shape of the nozzle making contact with the edge of the washer. a 2mm adjustment should give plenty of room for variance.

I need a printer to be able to adjust this precisely.

When updating Z offset via GLCD, it does not save once clicking in the button as before. Please update to automatically save settings onces this is updated.

We need to home the Z axis when first powering on

Fixed in .105

@marcio Checking with .108 redgum we are not homing when Z when first turning on the printer.

We would also like to move the "games" option to the advanced section. Checking with marketing we don't think it should be on the main screen. (This will go for all FW's with that enabled"

@karrad: How about the "About Printer" submenu for the games? Seems a little more logical than "Advanced Settings"?

@marcio About seems it should be printer statistics and firmware. Thoughts on interface settings, perhaps a second button next to customize sounds?

@karrad: The little games only show up on the RepRapDiscount display, so Quiver will not have them. So Interface Settings is not an option.

I could make it a bit sneaky and put it in the About Printer menu, but have it be a blank menu item, or make it so you have to scroll down all the way to the bottom, so it's more of an easter egg. I think that would be sort of cool.

karrad added a comment.Apr 5 2019, 3:10 PM

@marcio Ahh, reprap only. Yeah lets go with About Printer. I don't think we will need to hide it though, if we get complaints/issues from schools or other organizations we can remove it.

marcio added a comment.Apr 5 2019, 3:21 PM

@karrad: But hiding it is more fun!

marcio added a comment.Apr 5 2019, 3:22 PM

@karrad: I already made the change, take a look and if you don't like it's easy to unhide it. I'll push it to buildbot.

marcio added a comment.Apr 5 2019, 3:24 PM

@karrad: It will be .109

west added a comment.EditedApr 11 2019, 11:45 AM

The x min position is -32, for dual compatibility we need to change it to -51 for dual v3 compatibility
Also the z doesnt home when powered on in .109

west added a comment.Apr 11 2019, 12:19 PM

@marcio the nozzle is centered over the front left washer x=2

west added a comment.Apr 11 2019, 1:08 PM

@marcio x max = 295 y = 308

@marcio Testing 2.0.0.110 for redgum hardened steel, we are missing the home Z axis when first powering on.

adam added a subscriber: adam.Apr 25 2019, 12:21 PM

@karrad do we want to continue to collate marlin feedback on this ticket and move it to the beta column in redgum or close and open a new one?

@adam I will defer to you on that one, I reported here as it was originally said to be fixed here. If you want to close this out and split them up, please add me to the new ticket.

adam added a comment.Apr 25 2019, 12:39 PM

I think everything but the home Z has been taken care of or determined as "Won't fix" so as soon as we get the home z we can close this and just open separate tickets for new issues.

@adam: The home Z at startup doesn't seem to be working on the 8-bit boards. I can hear a small *thunk* at startup, but the axis doesn't quite move. Maybe the steppers take a while longer to initialize.

Well, fudge. The hint was right in the console:

echo:Unknown command: "<0x88><0x88><0x88><0x02>Yi<0xf0>HHHpHHH<0xf0><0x02>Yip<0x88><0x80><0x80><0x80><0x80><0x80><0x88>p<0x02>Yi<0xf0>HHHHHHH<0xf0><0x02>Yi<0xf8><0x80><0x80><0x80><0xf0><0x80><0x80><0x80><0xf8><0x02>Yi<0xf8><0x80><0x80><0x80><0xf0><0x80><0x80><0x80><0x80><0x02>Yip<0x88><0x80><0x80><0x80><0x98><0x88><0x88>p<0x02>Yi<0x88><0x88><0x88><0x88><0xf8><0x88><0x88><0x88><0x88><0x12>9i<0xe0>@@@@@@@<0xe0><0x02>Yi8<0x10><0x10><0x10><0x10><0x10><0x10><0x90>`<0x02>Yi<0x88><0x88><0x90><0xa0><0xc0><0xa0><0x90><0x88><0x88><0x02>Yi<0x80><0x80><0x80><0x80><0x80><0x80><0x80><0x80><0xf8><0x02>Yi<0x88><0x88><0xd8><0xa8><0xa8><0x88><0x88><0x88><0x88><0x02>Yi<0x88><0xc8><0xc8><0xa8><0xa8><0x98><0x98><0x88><0x88><0x02>Yip<0x88><0x88><0x88><0x88><0x88><0x88><0x88>p<0x02>Yi<0xf0><0x88><0x88><0x88><0xf0><0x80><0x80><0x80><0x80><0x01>Zjp<0x88><0x88><0x88><0x88><0x88><0x88><0xa8>p<0x08><0x02>Yi<0xf0><0x88><0x88><0x88><0xf0><0xa0><0x90><0x88><0x88><0x02>Yip<0x88><0x80><0x80>p<0x08><0x08><0x88>p<0x02>Yi<0xf8> <0x02>Yi<0x88><0x88><0x88><0x88><0x88><0x88><0x88><0x88>p<0x02>Yi<0x88><0x88><0x88><0x88>PPP <0x02>Yi<0x88><0x88><0x88><0x88><0xa8><0xa8><0xa8><0xa8>P<0x02>Yi<0x88><0x88>PP PP<0x88><0x88><0x02>Yi<0x88><0x88>PP <0x02>Yi<0xf8><0x08><0x10><0x10> @@<0x80><0xf8><0x11>;k<0xe0><0x80><0x80><0x80><0x80><0x80><0x80><0x80><0x80><0x80><0xe0><0x02>Yi<0x80><0x80>@@ <0x10><0x10><0x08><0x08><0x11>;k<0xe0> <0xe0><0x08>Sc P<0x88><0x01>Qa<0xf8>"␊

This had to do with the fact I wasn't storing the "G28 Z" command in PROGMEM, something that AVR requires. Easy fix.

@adam: I pushed .112. It should solve the homing Z issue. If so, go ahead and close this ticket.

adam closed this task as Resolved.Apr 26 2019, 9:54 AM