Page MenuHomeAleph Objects Inc

Windows 7 and problems with 250kbps serial USB communications.
Closed, WontfixPublic

Description

See ticket 200,592

Cura LE Version: 3.6.3

Operating System: Windows 7

Printer: TAZ 5

Tool Head: V2C

Description of issue: Customer cannot connect to Cura. When trying a firmware upgrade, Cura stops responding. When trying to connect to the printer Cura keeps searching for USB ports.

Steps to reproduce:

Had customer check baud rate and change communication speed from 11520 to 250000 and upgrade firmware. Unsuccessful. Had him change USB ports. Customer does not have different USB cable. Had him clean cache and reinstall. Had him check RAMBo driver and it is good. RAMBo driver on COM 6. Tried dedicating Cura to COM 6 without success.

Customer disabled virus scan software. No success.

Had customer download 21.08. Was able to do firmware upgrade and connect to Cura. Had him close out and try firmware upgrade in 3.6.3. No change

Upload cura-lulzbot.log (attachment) awaiting log file.

Event Timeline

johnson created this task.Apr 15 2019, 3:50 PM
karrad added a subscriber: karrad.Apr 17 2019, 11:55 AM

@johnson Can you reach out and try to get the log file? It looks like downgrading has him up and running, but we need more information to try to track this down.

alexei triaged this task as Normal priority.Apr 18 2019, 8:48 AM
alexei changed the edit policy from "Custom Policy" to "Cura LulzBot Edition (Project)".

@karrad request has been sent.

A second report here:

After uninstalling all Cura and Clearing the cash in both local and Roaming. I installed 3.66 and can still not reach the Taz Pro.

Still, It will not connecting to com7

jebba added a subscriber: jebba.Apr 22 2019, 2:49 PM

Screenshot shows bits per second (baud) at 128000, should be 250000 I think.

karrad assigned this task to Yahuba.Apr 26 2019, 7:50 AM
karrad added a subscriber: Yahuba.

@Yahuba Can you check your windows 7 machines and see what the allowable baud rate settings are?

@karrad
My system allows up to 128,000 when I have a Taz6 printer connected to it. However, I remember finding this link a while back that says that in the version of Win 7 version has .NET Micro Framework version 3.0 and above, the max baud rate max is 230,400. Im not 100% sure how accurate that is but here is the link: https://docs.microsoft.com/en-us/previous-versions/windows/embedded/dd187599(v=msdn.10)

alexei renamed this task from Cannot connect TAZ 5 to Cura to Windows 7 and problems with 250kbps serial USB communications..Jul 29 2019, 5:55 PM
alexei moved this task from Backlog to Release 3.6.xx on the Cura LulzBot Edition board.
bvivers added a subscriber: bvivers.Aug 4 2019, 9:55 PM

Please add bvivers@cox.net to this discussion. I am having communication problems with my mini. Windows recognizes the RAMBo, but CURA(old and LE latest) will not communicate with the Mini.

jebba added a comment.Aug 5 2019, 9:40 AM

@bvivers I think this issue just applies to the 3.6.x Cura, not the older one with the different interface. If you are having problems with BOTH, that may be a separate issue, perhaps with hardware. @bvivers Can you let us know specifically the versions you tested that aren't working? @Yahuba Do we know the range of versions this applies to?

I have only seen this occur in Windows 7 specifically with a Taz Pro printer. I have no other connection issues with any other printers on any systems I have tested on.

jebba added a comment.Aug 5 2019, 10:56 AM

@bvivers It sounds like you have a different issue. I would suggest contacting support@lulzbot.com or opening a new ticket here with details.

alexei closed this task as Wontfix.Oct 10 2019, 1:32 PM
alexei removed a subscriber: TyTh.