Page MenuHomeAleph Objects Inc

Averaged Layer Heights Mis-represented
Closed, ResolvedPublic

Description

The quality display section is not showing the properly averaged layer heights on dual extruder machines.

Steps to repoduce:
1.) Load TAZ Pro Dual Extruder machine
2.) Change e1 to High Detail Polylite
3.) Change e2 to High Speed Polylite PLA
4.) In quality, the layer heights properly average to 0.25mm
5.) Check quality selection, and it is still showing 0.35mm

Desired results:
Quality section shows actually averaged layer heights between the two

Event Timeline

karrad created this task.Apr 23 2019, 12:32 PM
karrad triaged this task as Normal priority.
karrad created this object with edit policy "Restricted Project (Project)".
matth added a subscriber: matth.Apr 23 2019, 2:35 PM

I think I have different desired results then. I'd like each extruder to display their own separate layer height settings, not have both display an average.

@matth Can you highlight where you would like to see this? As far as i know, to see individual settings for each extruder you need to swap back and forth and there is no spot to see them at the same time.

The slicer will require each extruder to use the same height to prevent collisions with the printed part during movement, which is why it will average those between the two.

jebba added a subscriber: jebba.Apr 30 2019, 12:00 PM

@karrad I'm seeing this in 3.6.7. See attached screenshot.

matth added a comment.EditedApr 30 2019, 12:03 PM

Okay, I get what you're saying. In that case there just needs to be some documentation to notify the user why they can't have both nozzles print at different layer heights.

Alternatively, in cura there could be 3 tabs: global, nozzle 1, nozzle 2. Things like layer height would be under global, while things like printing and standby temps would be listed under each nozzle tab. At the very least, there should be a distinction in between settings that affect both nozzles and individual ones.

Lastly, in 3.6.7, no matter what profile I pick it says it's 0.1mm. I couldn't replicate it in 3.6.6.

@TKostennov Can you give us an update on this display issue? It appears to be generating gcode properly for layer heights, just not displaying the correct average in the quality bar.

@karrad Fixed. Now layer height in quality bar calculates from extruders layer heights.

karrad closed this task as Resolved.May 1 2019, 8:26 AM
karrad added a subscriber: alexei.

@alexei This one looks good on a fresh build this morning, looks to be in master already. Closing this one down

jebba added a comment.May 1 2019, 9:03 AM

Do we know the commit that fixed this?

karrad reopened this task as Open.May 8 2019, 10:48 AM

@TKostennov Can we set the float on this to 3 digits? At the moment it is showing a lot of digits:

We would like this to just go to 0.XXX when rounding.

@karrad Fixed, check it please.

karrad closed this task as Resolved.May 10 2019, 10:10 AM

This one looks good, thanks @TKostennov