Page MenuHomeAleph Objects Inc

Taz Pro running into end of X axis when Extruder 2 selected
Closed, ResolvedPublic

Description

Noticed this while testing 3.6.9 on Mac OSX Mojave connected to Taz Pro. To reproduce:

Connect to printer, click "Home All" button in monitor screen,
From Monitor screen, Select Extruder 1.. once Extruder 1 is in down position, select Extruder 2

Once you select extruder 2, the nozzles switch and the entire tool head rams into the left end of X axis.

Event Timeline

Yahuba created this task.May 15 2019, 10:11 AM

Update: I was not able to replicate this when performing the same task from the LCD screen, so it's likely specific to CuraLE.

alexei changed the edit policy from "All Users" to "Restricted Project (Project)".May 16 2019, 7:56 AM
alexei triaged this task as High priority.
alexei claimed this task.May 17 2019, 10:51 AM
alexei reassigned this task from alexei to karrad.May 17 2019, 11:00 AM
alexei added subscribers: karrad, alexei.

@karrad ,
Could you please test proposed fix rCT99053612c1fe on TAZ Pro and TAZ 6.

karrad added a subscriber: TyTh.EditedMay 20 2019, 11:18 AM

@alexei This looks fixed on a Pro, I will need to try to find a dual extruder before I can check it out on the TAZ 6.

@TyTh Do you have any TAZ 6 dual extruders up in support?

karrad added a subscriber: nathan.May 20 2019, 11:40 AM

@TyTh @nathan Is hooking is up, thanks for checking in!

karrad reassigned this task from karrad to alexei.May 20 2019, 11:46 AM

@alexei No collisions on X axis when switching between nozzles when homed in all Axis for Pro or TAZ 6 v3 dual extruder

Should be good for review and merge

alexei closed this task as Resolved.May 24 2019, 9:45 AM

Merged to master.