Page MenuHomeAleph Objects Inc

Cura Lulzbot Edition won't start on Ubuntu 18.04 (glibc version problem)
Open, Needs TriagePublic

Description

Cura LE Version: tested on 3.6.13-3.6.18

Operating System: Ubuntu 18.04 (and other distros based on it, including PopOS and KDE Neon)

Printer: Taz Pro and Mini 1

Description of issue: The Cura Lulzbot Edition package available for download on the site and in your PPA is compiled against glibc 2.28. Ubuntu 18.04 uses glibc 2.27. 18.04 is a LTS release that a lot of us will stick with until the next LTS, which isn't until 20.04. I compiled 3.6.15 from source and was able to use it, but that is like a 2 hour process.

Steps to reproduce: Install Cura Lulzbot Edition 3.6.15 on a fresh install of Ubuntu 18.04. When you try to run it, you will receive the message:
/usr/share/cura-lulzbot/cura-lulzbot: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /usr/share/cura-lulzbot/cura-lulzbot)

Event Timeline

I built Cura LE 3.6.19 from source last night. This works fine. I think the issue must just be with how the debs are being prepared for Ubuntu.