Page MenuHomeAleph Objects Inc

libreadline7 not in Ubuntu 19.04 (disco)
Closed, ResolvedPublic

Description

Cura LE Version: N/A

Operating System: Ubuntu 19.04 (Disco)

Printer: N/A

Tool Head: N/A

Description of issue:

Ubuntu 19.04 does not have a package that satisfies the dependency for libreadline7. Disco has libreadline5 and libreadline8.

Steps to reproduce:

https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-ubuntu

The issue occurs at:

$ sudo apt install cura-lulzbot

Event Timeline

alexei added a subscriber: alexei.Aug 6 2019, 1:30 PM

@stochswarm : We're building debian packages on Buster for this Ubuntu version. There is no libreadline8 in it. Could you please try to install this package https://packages.debian.org/buster/libreadline7 first and see if it will fix the dependency problem?

alexei triaged this task as Normal priority.Aug 6 2019, 1:30 PM
alexei changed the edit policy from "Custom Policy" to "Cura LulzBot Edition (Project)".

Manually installing the Debian version allowed me to proceed and all is well. Thank you.

alexei closed this task as Resolved.Oct 10 2019, 1:37 PM