Page MenuHomeAleph Objects Inc

Cura LulzBot EditionProject
ActivePublic

Details

Description

This is the current release version of Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.

Cura is a Free Software program that both prepares your files for printing (by converting your model into G-Code), and also allows you to control the operation of your LulzBot 3D printer. Cura LulzBot Edition is based on Ultimaker's version of Cura available here: https://github.com/Ultimaker/Cura

Important links:
Information needed for issue tickets
Submit an issue ticket
Release planning and Issue management
Source code
Release builds
Development builds

Recent Activity

Today

karrad reassigned T2421: BUG: CuraLE 3.2.18 Changing parameters for extruder1 when modifying extruder2 from victor_larchenko to MattIC3D.
Mon, Apr 22, 2:46 PM · Cura LulzBot Edition
karrad assigned T2421: BUG: CuraLE 3.2.18 Changing parameters for extruder1 when modifying extruder2 to victor_larchenko.

@victor_larchenko This one is becoming more problematic, and we will need to get it sorted. Going to bump priority for now, please commit to a separate branch for testing.

Mon, Apr 22, 2:45 PM · Cura LulzBot Edition
karrad reassigned T6357: Nozzle Switch Location from victor_larchenko to anolen.

Once you have an update, please post here.

Mon, Apr 22, 2:44 PM · Cura LulzBot Edition
karrad lowered the priority of T6357: Nozzle Switch Location from Normal to Low.

@victor_larchenko While awaiting an update here, we are going to lower priority.

Mon, Apr 22, 2:43 PM · Cura LulzBot Edition
karrad added a comment to T6652: Cannot connect TAZ 5 to Cura.

A second report here:

Mon, Apr 22, 2:41 PM · Cura LulzBot Edition
karrad added a comment to T6357: Nozzle Switch Location.

@anolen Are you still seeing unnecessary moves that you would like to get fixed?

Mon, Apr 22, 2:29 PM · Cura LulzBot Edition
karrad reassigned T6756: Update Cura Splash Screen from karrad to DRobertson.

@DRobertson michael used to update these, I am not sure if there is a more "polished" source file somewhere. Attached you can see the existing .png for cura LE

Mon, Apr 22, 2:25 PM · Cura LulzBot Edition
karrad added a comment to T2421: BUG: CuraLE 3.2.18 Changing parameters for extruder1 when modifying extruder2.

@victor_larchenko We have an update to this one.

Mon, Apr 22, 2:22 PM · Cura LulzBot Edition
karrad triaged T6756: Update Cura Splash Screen as Normal priority.
Mon, Apr 22, 2:15 PM · Cura LulzBot Edition
karrad reassigned T6749: Update Quiver First Print Models from karrad to alexei.

@alexei Pushed to branch T6749 and ready for review

Mon, Apr 22, 11:22 AM · Cura LulzBot Edition
karrad triaged T6749: Update Quiver First Print Models as High priority.
Mon, Apr 22, 11:17 AM · Cura LulzBot Edition
karrad added a comment to T6335: Shortcut icons are huge.

@TKostennov Thank you for verifying the bug, we had a hard time duplicating it here. Thanks for the update.

Mon, Apr 22, 11:01 AM · Cura LulzBot Edition
TKostennov added a comment to T6335: Shortcut icons are huge.

@karrad
Sorry for delay with that. Problem caused by unusual dpi settings. Can reproduce this only on ubuntu 16 with non-standard dpi.
Trying to fix it, but don't have any full fix (for icons and for window size) yet.

Mon, Apr 22, 10:49 AM · Cura LulzBot Edition
Yahuba added a comment to T6646: Smoke Test 3.6.6.

@karrad I believe I was able to replicate on Win 7 with 3.6.6.
The RamBo driver shows up in device manager when printer is connected, so i connected a taz 6 to win 7, once I saw the driver appear, I uninstalled it.
Then disconnected printer, uninstalled CuraLE, cleared cache.
Next, I re-installed CuraLE 3.6.6; during the install was prompted with a Windows warning that Windows does not recognize the publisher of the drivers being installed, so I allowed the install anyway.
I reconnected the printer and launched CuraLE (leaving Dev Manager window open) and noticed that installing and launching CuraLE did not change the status of the uninstalled driver in Device Manager. CuraLE has a status of No Printer connected.
I then manually installed the driver from the link above and this time, Windows recognized this as the driver for the Taz6 and installed.

Mon, Apr 22, 10:31 AM · Cura LulzBot Edition
Yahuba added a comment to T6646: Smoke Test 3.6.6.

@karrad I attempted to update the driver in our windows machine. Whether I attempt to update using the drivers I downloaded from the link above or use the "search automatically for driver updates" feature in windows, I get a message from Windows saying the best drivers are already installed. If I attempt to connect to the Taz Pro, its getting stuck in the Auto-Detecting Baud Rate state indefinitely.
I then disconnected the Taz pro and uninstalled the RamBo driver. I reconnected the Taz Pro.. the system attempted to install the driver automatically and failed. I went back to the device manager and attempted to add the downloaded drivers but when I point Windows to those drivers it fails to recognize them as the drivers for the Taz Pro. Just want to make sure I am using the right driver, I downloaded the AO-101/TAZ driver. This is the one I should be using right?

Mon, Apr 22, 8:35 AM · Cura LulzBot Edition

Sat, Apr 20

victor_larchenko added a comment to T6670: Windows 7 Connection.

@Steven Tried to add some delays and disabled serial in firmware, to check if if printer issues, but this don't help. Only way that I was able to reproduce this when I disconnected usb cable from pc while connecting, so it looks like communication issues. Also sometimes I was seen that printer hangs on load, so may be that issues can be connected, but I not see it now while testing.

Sat, Apr 20, 7:25 AM · Cura LulzBot Edition

Fri, Apr 19

karrad updated the task description for T6020: Get RedGum into Cura LE.
Fri, Apr 19, 1:30 PM · Redgum, Cura LulzBot Edition
Steven added a comment to T6670: Windows 7 Connection.

@victor_larchenko any update on testing this issue with a RAMBO board? It would be either a TAZ 6, Mini, or Mini 2.

Fri, Apr 19, 1:09 PM · Cura LulzBot Edition
karrad added a comment to T6650: TazPro CuraLE 3.6.6 pausing prints automatically.

@Yahuba Any luck repeating this?

Fri, Apr 19, 9:54 AM · Cura LulzBot Edition
karrad added a comment to T6646: Smoke Test 3.6.6.

@Yahuba Please try to manually install the drivers on the Windows 7 system, and see if it resolves the connection issues. Guide can be found here: https://www.lulzbot.com/manually-installing-drivers-windows

Fri, Apr 19, 8:34 AM · Cura LulzBot Edition
johnson added a comment to T6652: Cannot connect TAZ 5 to Cura.

@karrad request has been sent.

Fri, Apr 19, 7:17 AM · Cura LulzBot Edition

Thu, Apr 18

Yahuba added a comment to T6646: Smoke Test 3.6.6.

PRINTER | OS | Resolution | toolhead | Result
Taz Pro | Mac OS X Mojave | 1680x1050 | Taz Pro Dual Extruder | pass
Mini 2 | Mac OS X High Sierra | 4096x2304 | LulzBot Mini 2 Aerostruder v2 Micro Tool Head (SL 0.25mm) | pass
Taz 6 | Mac OS X Sierra | 4096x2304 | LulzBot TAZ 6 Flexystruder v2 Tool Head | pass
Mini Mac OS X El Capitan | 1920x1080 | LulzBot Mini 2 Aerostruder v2 Tool Head (SE 0.5mm)| pass
Mini Mac OS X El Capitan | 1344x756 | LulzBot Mini Single Extruder Tool Head v2.1 | pass
Taz 6 | Mac OS X El Capitan | 1920x1080 | LulzBot TAZ 6 Single Extruder | pass
Taz 6 | Mac OS X El Capitan | 1344x756 | LulzBot TAZ 6 Single Extruder | pass
Mini | Win 10 | 1920x1080 | LulzBot Mini Single Extruder v2.1 Tool Head | pass
Mini | Win 10 | 1366x768 | LulzBot Mini Single Extruder v2.1 Tool Head | pass
Mini | Win 10 | 1920x1080 | LulzBot Mini Macro Extruder (HS 0.8mm) | pass
Taz 6 | Win 10 | 1920x1080 | LulzBot TAZ Dual Extruder Tool Head v3 | pass
Taz 6 | Win 10 | 1366x768 | LulzBot TAZ Dual Extruder Tool Head v3 | pass
Mini | Win 7 | 1920x1080 | LulzBot Mini Single Extruder Tool Head v2.1 | pass
Mini | Win 7 | 1280x720 | LulzBot Mini Single Extruder Tool Head v2.1 | pass
Taz 6 | Win 7 | 1920x1080 | LulzBot TAZ Dual Extruder Tool Head v3 | pass
Taz 6 | Win 7 | 1280x720 | LulzBot TAZ Dual Extruder Tool Head v3 | pass
Mini Ubuntu 16.04 | 1920x1080 | LulzBot Mini Aerostruder v1 Tool Head | pass
Mini Ubuntu 16.04 | 1152x864 | LulzBot Mini Aerostruder v1 Tool Head | pass
Taz 6 | Ubuntu 16.04 | 1920x1080 | LulzBot TAZ MiniMOARstruder (1.20)| pass
Taz 6 | Ubuntu 16.04 | 1152x864 | LulzBot MiniMOARstruder (1.20)| pass
Mini | Ubuntu 18.04 | 1920x1080 |LulzBot Mini Aerostruder v1 Tool Head | pass
Mini | Ubuntu 18.04 | 1152x864 | LulzBot Mini Aerostruder v1 Tool Head | pass
Taz 6 | Ubuntu 18.04 | 1920x1080 | LulzBot TAZ MiniMOARstruder (1.20)| pass
Taz 6 | Ubuntu 18.04 | 1152x864 | LulzBot TAZ MiniMOARstruder (1.20)| pass
Taz Pro | Debian Stretch | 1920x1080 | Taz Pro Dual Extruder | pass/fail - T6650
Taz Pro | Debian Stretch | 1152x864 | Taz Pro Dual Extruder | pass
Taz 6 | Debian Stretch | 1920x1080 | LulzBot TAZ 6 MOARStruder Tool Head | pass
Taz 6 | Debian Stretch | 1152x864 | LulzBot TAZ 6 MOARStruder Tool Head | pass

Thu, Apr 18, 10:34 AM · Cura LulzBot Edition
alexei triaged T6652: Cannot connect TAZ 5 to Cura as Normal priority.
Thu, Apr 18, 8:48 AM · Cura LulzBot Edition
karrad updated the task description for T6020: Get RedGum into Cura LE.
Thu, Apr 18, 8:16 AM · Redgum, Cura LulzBot Edition
alexei added a comment to T6671: Cannot Load Model Windows 10 64 bit Cura 3.6.3.

@zachah , What is the source of the attached screenshot then? Could you please get cura logs, because it's hard to tell what is going on without them.

Thu, Apr 18, 8:04 AM · Cura LulzBot Edition
alexei closed T1868: Add Quiver to Cura LE as Resolved.

@karrad , this was actually in the master rCT05d810c741e5e1fc4988c180a0c1638c564b2543 and released in devel with 3.6.6 tag.

Thu, Apr 18, 7:57 AM · Cura LulzBot Edition, Quiver

Wed, Apr 17

zachah added a comment to T6671: Cannot Load Model Windows 10 64 bit Cura 3.6.3.

Those brackets are just a result of me downloading the zipped file multiple times. I verified with the customer that their directory does not have brackets in it. Their folder is just curved-j/curved-j.stl

Wed, Apr 17, 5:32 PM · Cura LulzBot Edition
karrad added a comment to T6652: Cannot connect TAZ 5 to Cura.

@johnson Can you reach out and try to get the log file? It looks like downgrading has him up and running, but we need more information to try to track this down.

Wed, Apr 17, 11:55 AM · Cura LulzBot Edition
karrad updated the task description for T6020: Get RedGum into Cura LE.
Wed, Apr 17, 11:16 AM · Redgum, Cura LulzBot Edition
karrad added a comment to T6670: Windows 7 Connection.

@victor_larchenko These reports have been on 3.6.3 connecting to the RAMBO boards included on the TAZ 6 machines. Can you test on there? We will attempt to get some error logs for you today as well

Wed, Apr 17, 9:13 AM · Cura LulzBot Edition
victor_larchenko added a comment to T6670: Windows 7 Connection.

@karrad Tried to reproduce this issue, but all attempts were unsuccessful. Used windows 7 on virtual machine hosted on ubuntu and taz 7 motherboard. Alse changed COM ports numbers for printer(3-256).
Can you please post log file and maybe some remarks on how to reproduce this?

Wed, Apr 17, 8:42 AM · Cura LulzBot Edition
alexei added a comment to T6671: Cannot Load Model Windows 10 64 bit Cura 3.6.3.

I noticed on attached screenshot, that the name of the directory has brackets in it:

D:/3D Printers/lulzbot/Cura/curved-j(4)/curved-j.stl

So most probably this is the reason why it's failing.

Wed, Apr 17, 7:16 AM · Cura LulzBot Edition
alexei triaged T6671: Cannot Load Model Windows 10 64 bit Cura 3.6.3 as Normal priority.
Wed, Apr 17, 7:13 AM · Cura LulzBot Edition

Tue, Apr 16

zachah created T6671: Cannot Load Model Windows 10 64 bit Cura 3.6.3.
Tue, Apr 16, 9:24 PM · Cura LulzBot Edition
karrad updated the task description for T6020: Get RedGum into Cura LE.
Tue, Apr 16, 4:41 PM · Redgum, Cura LulzBot Edition
karrad updated the task description for T6670: Windows 7 Connection.
Tue, Apr 16, 4:38 PM · Cura LulzBot Edition
karrad changed the edit policy for T6670: Windows 7 Connection.
Tue, Apr 16, 4:38 PM · Cura LulzBot Edition
karrad triaged T6670: Windows 7 Connection as High priority.
Tue, Apr 16, 4:38 PM · Cura LulzBot Edition
karrad triaged T6669: Baud Rate as Normal priority.
Tue, Apr 16, 4:35 PM · Quiver, Cura LulzBot Edition
karrad updated the task description for T6020: Get RedGum into Cura LE.
Tue, Apr 16, 2:13 PM · Redgum, Cura LulzBot Edition
karrad merged T6662: Change message in start g code into T6020: Get RedGum into Cura LE.
Tue, Apr 16, 2:12 PM · Redgum, Cura LulzBot Edition
karrad added a project to T6020: Get RedGum into Cura LE: Redgum.
Tue, Apr 16, 2:12 PM · Redgum, Cura LulzBot Edition
karrad reassigned T1868: Add Quiver to Cura LE from TKostennov to alexei.

@alexei Ready for review and merge, this should be the end of T1868.

Tue, Apr 16, 11:54 AM · Cura LulzBot Edition, Quiver
karrad added a comment to T1868: Add Quiver to Cura LE.

@TKostennov Sorry for the delay there, it does look like a cache clear issue. Thanks for getting it sorted!

Tue, Apr 16, 11:53 AM · Cura LulzBot Edition, Quiver
karrad updated the task description for T6020: Get RedGum into Cura LE.
Tue, Apr 16, 11:27 AM · Redgum, Cura LulzBot Edition
Yahuba added a comment to T6646: Smoke Test 3.6.6.

Tested in Windows 10 and connected succesfully over Com port 4

Tue, Apr 16, 9:44 AM · Cura LulzBot Edition
Yahuba added a comment to T6646: Smoke Test 3.6.6.

OK, I was able to replicate this in Windows 7. In my case it was trying to connect to Com Port 10

Tue, Apr 16, 8:59 AM · Cura LulzBot Edition
Yahuba added a comment to T6646: Smoke Test 3.6.6.

Ive tested 3.6.6 on Win 7 with a Taz6 (Dual v3) and haven't run into any connection issues. I just connected to it again and it uses com port 5 (which is typically what I see). As I understand it: Windows 7 assigns new com port numbers to each new device attached to the machine (i believe the range is between 1-255?) and it remembers that device the next time its connected to the machine and assigns that same port number. Any new device to the machine gets assigned the next available com port number. So it could be that port 7 was the next available port number their machine has assigned to the new device. Does Cura look for a specific range of port numbers?

Tue, Apr 16, 8:27 AM · Cura LulzBot Edition
Yahuba added a comment to T6650: TazPro CuraLE 3.6.6 pausing prints automatically.

@karrad - yes, the first attempt printed about 30% before it failed. Then I tried again immediately after, and then second time, it printed for about 2 seconds and immediately went into a pause state. After that attempt, I decided to switch filament to see if it was the type of filament I was using and I noticed that the filament was almost our of the extruder. I was able to pull the line out without retracting filament. I will try and replicate again today and post logs.

Tue, Apr 16, 8:14 AM · Cura LulzBot Edition

Mon, Apr 15

karrad updated the task description for T6020: Get RedGum into Cura LE.
Mon, Apr 15, 3:58 PM · Redgum, Cura LulzBot Edition